Versionskontrollverlust

Gegen den zügigen Wechsel auf Python 3 spricht nicht nur die fehlende Anpassung externer Module und Frameworks, sondern auch das großartige Modul argparse, das ausschließlich in Python 2.7 und Python 3.2a3 verfügbar ist. Das stabile Python 3.1 enthält nur das weniger leistungsfähige optparse. Bisher kommen Python 2.5, 2.6, 2.7 und 3.1 auf meinem Mac ganz gut miteinander aus, aber ich freue mich jetzt schon auf den 22. Januar 2011.